Django & Ubuntu issues

I’ll try it out tomorrow. But another question. There are these two USB images with Ubuntu 16.04 Kinetic and Ubuntu 18.04 Melodic respectively. I use Ubuntu 18.04 on the laptop - it is only annoying, since it takes forever to load. Unfortunately, these images do not offer any possibility that I know of to install it. I once installed an 18.4 based on LUBUNTU - because it eats less resources and runs great on IBM hardware. Unfortunately, installing Melodic is a little adventure and it didn’t really work out in the end. Therefore I am currently only using the USB image with Melodic. I have no idea how to get it to run on a hard drive next to Windows 7. The solution would be an installable image with Grub, …

These images are not meant to be installed on your computer drive.

Could you tell us more what kind of problems did you have? I never had a problem with installing ROS on any LTS Ubuntu-based distribution. It was always a matter of executing a few commands (adding repository to apt lists, adding ROS GPG key, installing packages).

I suggest creating a new topic as this isn’t related to LeoOS.

When you follow the instructions to install Melodicon Ubuntu 18.04 the Keys didn´t work. You have to install the shadow-fixed repository. After all you have different path´s for all. That´s for Linux/ Ros Noobs like me not really fixable. I´ve tryed to connect with Leo and Ros told me that a lot of componets are missing - but i´ve installed them. I don´t know the Problem .

I remember that at one point the ROS GPG keys were changed due to a security issue with build farm (that was around 1 year ago, I think). Maybe you tried to follow instructions that were not updated for the new keys. I suggest trying again now with the ROS Wiki Instructions.

OK, but doesn´t work again . —> Cant find Packages. I´ve did the instructions from ROS WIKI . I´ve changed the source also (Europe. Germany). But no luck

Can you paste the exact command you are executing and the error message?

Also, please show me the output of these commands:

lsb_release -a
cat /etc/apt/sources.list.d/ros-latest.list
sudo apt-get update

It´s working now. I´ve found an other Instruction to install 18.04 and Ros Melodic. .

That is not working : The Problem is simple. It gives no “Full” or similar packages. So you have use the Source and cook your own .

I would not recommend maintaining a Source installation of ROS. You may have successfully built a basic set of packages, but any time you want to install a new package from the distribution or update the already installed ones, you will have to manually download the source code and compile it (which takes a long time for some packages). Whereas, if using the ROS repository, you have access to nearly 3000 packages already pre-built for your architecture, which are periodically updated.

If it does not bother you, you can go with it, but any time you will post about a problem regarding installation of some package from ROS distribution, I will send you back to this thread.

Otherwise, please show me the full output of the command you are executing to install ROS, as well as the commands I send you in the previous post.

sudo apt install ros-melodic-desktop-full --> Can´t find Packages !!!

sudo apt install ros-melodic-desktop --> Can´t find Packages !!! ,…

Thats all, ive changed to different servers - but it gives no FULL or DESKTOP or similar Packages. <----- based on this instructions.

I´ve tryed also 6 different Internet Connections -> 4 without Firewalls and similar

I think that something fundamental is also misunderstood here. It’s not about a LEO OS (no idea what it is for) but it’s about a laptop ROS Ubuntu installation.

If I have time I will do a screen recording, because I have no desire to write 120 error messages and forever found the same --.-> no XXX. APT list are current and everything is entered

ive posted a video on FB

I think I know what the problem might be but I need more data to confirm it. Please show me the output of these commands:

uname -a
cat /proc/cpuinfo | grep 'model name' | uniq

i will post on FB in case of making videos

You have installed the system for the i386 (32-bit) architecture. Since the Melodic distribution, the packages are no longer built for this architecture. You have to install the amd64 (64 bit) version of the system.

ok, that not possible. Thank you for your help

I don’t know if I understand you correctly. As far as I know, you processor supports 64 bit architecture If that’s your concern.

Works for now whit an other Laptop and 64Bit

Now i am playing with Autonomus navigation. I am not shure what i make wrong :
roslaunch leo_navigation odometry.launch —> works
roslaunch leo_navigation odometry.launch 3d:=true ----> didn´t work (IMU works fine) but no movement in the Axis (Pich,Roll)), odometry works
roslaunch leo_navigation navigation.launch -> didn´t work (can´t find) .

I´ve used exactly your Guide .

The Problem is that under 64 Bit i have Desktop Freezes and the whole System is not stable. So i´ve tryed the 32Bit Version.

I added the navigation.launch file yesterday.

Please create another topic for the rest of your problems as they don’t relate at all to this thread.

I moved the discussion to another topic to keep the previous one clean.

There was some issue with the argument name. I changed 3d to three_d and it worked. Could you try again now?