Unable to connect additional UI

I have been attempting to include an additional UI to my LeoRover, but have been unsuccessful in correctly connecting it to the rover. I have tried configuring the nginx service but have been unsuccessful as the file that is specified in the tutorial is not located in the cloned UI files that I have downloaded to my computer. How canI go about configuring this nginx service and is it the reason why I cannot connect my additional UI to the rover?

Thank you in advance!

Hi, @Piotr should help here.
Can you specify which file is missing?

Hi! Great hope they can help us.

On the rover documentation site, it says we must locate the file where we need to configure the nginx service.

Hi, so I was able to install nginx, but apparently the sites enabled folder is only for linux machines. Are there instructions on how to get the nginx service up and working for windows or macOS?

In your first message, you mentioned that you cloned the UI files to your computer- and here is the problem :wink: The configuration described in the mentioned tutorial needs to be processed in the LeoOS system (LeoRover’s default system running on RPi). I forgot to mention this important information in the tutorial- I have already fixed it. Check the tutorial again, especially the paragraph “Prepare the Rover before start”.
The additional UI as well as the default one is hosted on the LeoOS.

Hi Piotr! Thank you so much for the clarification. I am currently following the guide and have just one last question if you don’t mind. So for the NetworkManager how is this going to help us with attaching our additional UI to the LeoOS? Can you give us a little background please?