[SOLVED] (Steering the Rover with a joystick)] no reaction to rover

Hi all

I try to follow this tuto : Steering the Rover with a joystick

The cmd rosrun joy joy_node, rostopic echo /joy, work well on the pc, rostopic echo /battery returns the battery value.

No error when i launch : roslaunch leo_joy_example joy.launch

... logging to /home/florian/.ros/log/e47a02ac-7a16-11ec-b4d9-f469d5800a7b/roslaunch-XX-29919.log
Checking log directory for disk usage. This may take a while.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server


 * /joy_node/autorepeat_rate: 30.0
 * /joy_node/coalesce_interval: 0.02
 * /joy_node/dev: /dev/input/js0
 * /rosdistro: noetic
 * /rosversion: 1.15.13
 * /teleop_node/axis_angular: 0
 * /teleop_node/axis_linear: 1
 * /teleop_node/enable_button: 5
 * /teleop_node/scale_angular: 2.0
 * /teleop_node/scale_linear: 0.4

    joy_node (joy/joy_node)
    teleop_node (teleop_twist_joy/teleop_node)


process[joy_node-1]: started with pid [29934]
process[teleop_node-2]: started with pid [29935]
[ WARN] [1642703633.781296680]: Couldn't set gain on joystick force feedback: Bad file descriptor

Any idea?


Are you holding down the enable button on the joystick?

Yes, i am.

It’s my fault, the problem solved, it’s an error in the : export ROS_IP. The good value is
if it can help, cmd ip address return :

3: wlp13s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether bc:85:56:a0:8d:a3 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute wlp13s0
       valid_lft 41464sec preferred_lft 41464sec
    inet6 fe80::9d77:a8b6:dc84:99c3/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever