Missing graphical interface and SSH issues

Hello everyone
In the process of processing software
Lubuntu related files were deleted by mistake
It can’t be displayed correctly on the interface.
Would you like to ask without affecting the current settings
How to solve or reset LeoOS

In addition, when setting the VNC viewer
Some plug-ins are installed, which requires login to use SSH after booting.
It is not used in the original situation
How can I solve it

Do you know which exact files were deleted?

One of them is part of lubuntu

My situation is yesterday I used VNC through online teaching
It should be installed through the instructions of tightvncserver
Then I turned it on today and found that I could not use PUTTY to connect to SSH
So I removed the pi and STM32 and used HDMI to watch
It was found that the screen was changed to the login screen of LXDE instead of the native interface of LeoOS
I use the text interface to log in to use SSH

So I originally thought that the problem could be solved by removing LXDE and the interface
It turns out that there is no and you also need to log in to use SSH
Cause such a situation
I’m sorry

Lubuntu session uses LXDE. When you connected to HDMI you probably saw the LightDM login screen.
If you could tell me the paths of the files you removed, I could probably find out which package needs to be reinstalled, but I can’t guarantee I will be able to fix everything.
Why not just reflash the LeoOS image and redo the changes you have made?

sudo apt purge --remove lxde*; sudo apt autoremove -y
sudo apt purge --remove lubuntu-*; sudo apt autoremove -y

I used the above to remove LXDE

Because I am a beginner
No experience in this area
The process alone is enough to break me…haha

Try reinstalling lubuntu-core package:

sudo apt install lubuntu-core

I have just tried to install lubuntu and it has roughly solved the current problem
Not sure if there will be other problems, but no
Thank you so much!!!