Hokuyo Lidar integration problems

Hello,
Thank you very much for your nice support.
We hope your kind support will be help us in finishing our Rover and running smoothly in short time.
But we still get problem in programming after study carefully your instruction in website.
Would you like summarize the procedure in ROS with Hokuyo Lidar sensor ?
We used UBUNTU MATE 18.05 LTS in our PC. How to set up ROS ? We followed your steps but no works.
We already established internet wifi for our Rover . Display of Leo Rover showed voltage 0V but battery still worked .What wrong with it ?
Thank you
Best regards

Thanh Phan
Note : we’re unable to send email to you because UNSOLICITATED BULK EMAIL

Hi, I moved you post to a new topic, because it was not related to the original one.

The battery voltage is measured by the CORE2 board and the UI displays 0V by default if it does not receive any measurement. So in your case, is it to be expected.

You need to describe your problems more specific. I assume tried to follow this tutorial. Which steps have you completed and which steps have you had problems with? Were you able to complete the tutorial up to the point where the data is published on the /scan topic, i.e. the command:

rostopic echo /scan

prints the raw measurements ?

Dear Blazej_Sowa,
What we means in one of these following troubles :
Extra: Troubleshooting - Leo Rover.
Do you known that is firmware of Core 2 ?
We think Leo only suitable to Ubuntu 16.04 .Some commands unknown when we proceed in Ubuntu 18.05 or 20. If it is problem, we will back to Ubuntu 16.04.
Did Leo need python 3.3 or openCV ?
Thank you

Could you give an actual example of what you are trying to do (any command, for example), what do you expect to happen, and what actually happens (some error outputs would be helpful)?

Did you try the newest LeoOS or some other Ubuntu-based distribution? What commands which were available on the previous distribution did you found to be missing (concrete examples please) ?

I don’t think so.

We used other kind of DC gear motors instead of your Buehler Motor 1.61.077.414 (31x88).
That is JGA 25-371 from YFROBOT Maker .Is it OK ?
You may have issues with the encoder pount per revolution as it’s different than the one we use with Buehler. If it bevahes super strange, you can change settings as here:
http://wiki.ros.org/leo_fw
You can as well open a new topic in the forum and maybe Błażej will help you do it.

@Blazej_Sowa this is a quote of what I wrote in PM to @thanhthanh (just to make it clear)