Core 2 Ros Board update failing

I’ve been trying to update the Core 2 Ros board, following the procedure here:
The screenshot of the result (by SSHing into the Leo) is attached below.

The first error message (connecting to bootloader … UNABLE) occurs when connected to the Core 2 Ros board with a usb cable.

The bottom error code (plug in Husarion device) occurs when the board is not connected. I include both to confirm that I am plugging into the board correctly.
I am using a standard micro usb cable: this one to be precise.

I get the same outcome if I connect the Board to my PC and follow their instructions for updating.

Could you try disconnecting the CORE2 from Raspberry Pi and then flashing the firmware from your PC?

I’ve removed the board from the rover, and connected it to my PC. Unfortunately I still get the same result:

Just to be sure: Have you tried different USB cables?

Yes, I’ve tried 2 different usb cables, both of which have successfully been used to transmit data in the past.

As we talked internally with @Blazej_Sowa the issue may happened due to some error during the bootloader update (like connection cut, etc.)
So, what we’ll do is we’ll send you new Core2-ROS and would be glad to receive your current one to be able to troubleshot it for the future. Ofc, wait for the new one to arrive before you send back the faulty one.
Just wondering, with the issue occuring, does the Rover work on the board or it just stopped working?

Hi Szymon,
That would be great. At present the Rover is working exactly as expected, with no other issues aside from the one mentioned above.