Cannot login as root user


I am curently planning to communicate with the Arbotix arduino throught the serial port of the Raspberry.

My goal is to make a button on the web interface that sends chars throught the serial port which corresponds to differents sequences of movement on the Arbotix controller.

For that, I need to install node.js but Ubuntu won’t let me because I don’t have root acces.

Trying to do so results in a denial of permission to edit /etc/ssh/ssh_config which prevents me from removing the security.

How can I remotely acces root user ?

If you are logged as the default user (pi) then you can execute commands with root privileges using sudo, for example:

sudo nano /etc/ssh/ssh_config

Hello, I solved the problem by defining a Root password. The first time I tried, I must have entered two different passwords and took it for a denial of access, since I could not see what I was typing. Trying it a second time finnaly allowed me to log in successfuly. Thanks for your response.

Just a quick note:

To access the root user, it is not necessary and generally not recommended to set the Root password.

The pi user already has permissions to execute commands as the root user, you just need to use sudo like this:

sudo <command>

or you can open an interactive root shell:

sudo -s

and then execute commands as the root user. Working in the root shell should be used with caution as it gives you total control of the system and a simple typo in the command can destroy a running system.