Leo rover mast

Please insert into the tutorial:

  1. Flash ArbotixM.

-If you follow the instructions and want to flash the controller, it is important to take the old IDE (1.0.6). So it works smoothly.

Before flashing, it is important to set the jumper (power) to “USB”. Only after flashing again on Ext.

  1. Please update the tutorial to the current ROS version (kinetic?).


cd ~ / ros_ws / src
git clone https://github.com/LeoRover/leo_mast_bringup.git

-> Fatal error. Port 443 unreachable.

rosdep update
-> Fatal error. Same.

I think it’s a network problem. I googled something and there is talk of proxy servers … No plan. I use remote Desktop from a Win10 Mashiene. SDP is running nice and all the other Stuff.

Have leo_mast_bringup installed locally. The servos also go so far - but the lift / relax function does not. There are no services for this command either. Servo 3 and 2 can be easily spread over the WEB UI.

so mast / lift and mast / lower are missing.

On the ArbotiX-M Robocontroller guide, we referred to the ArbotiX-M Robocontroller Getting Started Guide from TrossenRobotics for the flashing part. It already covers the parts about the Arduino IDE versions and the setting the power jumper. Did you perhaps follow another tutorial to flash the Arbotix board?

Could you point out what part of the tutorial is outdated?

Do you have Internet connection on your Rover? Is so, it seems like something is blocking HTTPS port on your network.

Are there any errors when you ran:

roslaunch leo_mast_bringup leo_mast.launch

Also, could you paste the output of these commands:

rosnode list
rostopic list 
rosservice list

Arbotix-M Controller

  1. Test the ROS driver

mkdir -p ~/ros_ws/src && cd ~/ros_ws/
catkin init
catkin config --extend /opt/ros/melodic <--------

The Arbotix Guide is perfect. You can quickly overlook that. It worked fine for me - but in the heat of the moment …

The same applies to the FTDI-USB controller. For example, some people have a DTR PIN instead of RTS / Reset. This creates confusion for some people. It is the same and works perfectly. It is important for the people who build the FTDI cable themselves in order to get proper wiring. In my case, this is appropriate because the controller is housed in the MEB.

I will give you the Output tomorrow .

Soo, today I tried another internet connection. Could clone everything from Github .Leo_Mast_Bringup cloning does not work. Since he said no proxy server found again. However, the said port is free and is not shown in the error message. The Mast_relax, Joint services are missing when I display the Rostopics, Servises, … Joint 2 and 3 are there and also work. Will set up the image again and continue to report

Everything is fine now. I have reinstalled the hole Image. But how can I setup the Speed ? Servo 1 is too fast .

Hm, so you just needed to redo the thing? I’m wondering what changed to be able to add some notes to the tutorial.

I had the wrong ROS drivers / … installed. As appears in the Arbotix tutorial. I’ve now switched everything to Kinect. So it went smoothly. Inexperienced people quickly fall into such a trap - even with the jumper on the Arbotix controller. But in the end you just have to be careful. :-). Now I am searching for the Settings -> to spped down the Servo 1

1 Like

You can modify the leo_mast_bringup/config/leo_mast.yaml file. For each servo there is an option called max_speed which you can use to set the maximum speed in degrees per second.

1 Like

It worked great. I experimented a little with the values ​​and got a good result. How can you implement a button in the Web UI that drives e.g. Servo 3 to a certain position?

–SOLVED-- . It works fantastic.